1. Quais são os dois tipos de representações mais utilizados em algoritmos?
Fluxograma e pseudocódigo

2. Verifique se a afirmação é verdadeira ou falsa. Uma expressão literal sempre resultará em um tipo literal.
Verdadeiro

3. Informe qual alternativa é de fato o nome de uma variável aceita no VisuAlg:(Questão Múltipla Escolha)
tipo_operacao
meuResultado
1numero
nota1

4. Informe qual resultado da expressão aritmética será exibido no algoritmo a seguir:
var
x,y,resultado: Real
inicio
x <- 2
y <- 5
resultado <- x/y*3+(1-8)*x+30
escreva (resultado)
fimalgoritmo
R: 17.2

5. Seguindo a ordem, diga os significados dos seguintes operadores lógicos:
>, <, >=, <=, =, <>
Maior, menor, maior ou igual, menor ou igual, igual, diferente.

6. Abaixo teremos o início da estrutura de repetição para..faça. Informe qual a forma correta de se fazer:
Para variavel de 1 ate 2 faca

7. Escreva o resultado final do algoritmo abaixo:
resultado <- 1
resultado <- resultado+ 10
se (resultado = 10) entao
escreval ("SE")
senao
escreval ("SENAO")
fimse
R: Entrará no SENAO

8. Quais as vantagens de se utilizar variáveis indexadas? (Questão Múltipla Escolha)
Menos código
Guardar mais valores


9. Diga o resultado final das duas questões utilizando os seguintes operadores de sentença:

((1=1) ou (2<>2))
(5>2) e (3<>2) e (10 >= 100)
R: Verdadeiro e falso


10. Observe a seguinte expressão e responda qual será o resultado final:

a <- 8.5
b <- 10.2
((a*4/2)+b > a+b)
Verdadeiro